カテゴリー:
Rails
タグ:
 rmagic ImageMagick

このエントリーをはてなブックマークに追加
更新日時:
2012年10月29日(月)
作成日時:
2012年10月29日(月)

前の記事 / 次の記事

bundle install して rmagick を入れようとしたら入らなかったのでメモ。

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

        /usr/local/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
extconf.rb:128: Use RbConfig instead of obsolete and deprecated Config.
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.13.1. Can't find Magick-config 

と言われたのでぐぐる。

環境:CentOS6.3, Rails3.2.8, Ruby1.9.3p286, ImageMagickはインストール済み

【参考ページ】
・rails環境再構築
http://d.hatena.ne.jp/fuyunoarashi/20090228/p1

ImageMagick-develなるものがあるらしいので入れる。

$ yum install ImageMagick-devel

で、再度 bundle install してインストール出来た。